Creating Meta Devices (virtual partitions) with Disksuite ---------------------------------------------------------------------------------- Adding the Disksuite software 1) Install the software packages off of the Solaris Easy Access Server (2.0-3.0) # cd /cdrom/cdrom0/Products/DiskSuite_4.2/sparc # pkgadd -d . SUNWmd* 2) Modify root's path: # vi /.profile PATH=$PATH:/usr/opt/SUNWmd/sbin MANPATH=$MANPATH:/usr/opt/SUNWmd/man 3) # reboot -- -r #! The easiest way to ensure that all servies will be running. 4) # metadb -a -f -c4 c*t*0*s* c*t*d0s* 5) # metadb -i #! This will create state database replicas on two different slices for fault tolerance. Replicas do not need #! exclusive rights to file systems, but it is recommended if resources are available. Step 5 will verify that #! the replicas have been created. 6) # vi /etc/opt/SUNWmd/md.tab d1 2 1 /dev/dsk/c*t*d0s* 1 /dev/dsk/c*t*d0s* #! These two slices will be concatenated. Use different partitions on different hard drives if possible. Be #! sure the device is not on the same slices as your state databases. 7) # metainit d1 #! Initialize the metadevice 8) # metastat 9) # newfs /dev/md/rdsk/d0 10) # mkdir /meta_device_directory 11) # vi /etc/vfstab /dev/md/dsk/d0 /dev/md/rdsk/d0 /meta_device_directory ufs 2 yes - #! Be sure to delete any old entries that contained one or both of the partitions that are being concatenated. #! fsck will return errors when trying to verify conflicting entries. 12) # umountall -l 13) # mountall -l 14) # df -k #! The virtual partition /meta_device_directory should now be mounted.